Firefox/OSX/Flash problem

Just a question for the intertubes: is anyone else having problems with Firefox and Flash on OSX? I’m having this REALLY weird issue where flash content (Youtube, blog badges, etc) doesn’t display except when it is near the top/bottom of the Firefox window. Yes, you read that right…if the content overlaps the bottom/top edge, it displays. Get off the edge, and it doesn’t display (the content just goes invisible, it doesn’t un-render or anything, just goes away/becomes invisible).

WTF?

31 thoughts on “Firefox/OSX/Flash problem

  1. Huh. Weird. I’ve been using 2 macs for a while now (just got my new MacBook + Parallels at work!!!) and I haven’t seen anything funky on YouTube or any of the other Flash video sites. Dunno.

  2. Yes! This is driving me nuts. It’s happened on two Macs I’ve worked with and I can’t find a solution.

  3. I have this problem too, and it’s a pain in my sweet patooty. Found your site hoping somebody had a solution – I can’t even find any other mention of it on the interwebs. It’s that way on both of my computers. Have you found any workarounds?

  4. I’ve had a similar problem. I can’t get any flash content to work in Firefox on Macs. I have a PPC mini and my gf has a macbook. Flash works in neither with firefox. Works fine in Safari, except that I can’t stand safari…

  5. Hey me too ! 🙂

    I hate that bug. Cant find any solution for it. If you find out please mail me about it !

    Thanks !

    🙂

  6. Hey !

    Found a solution that worked for me:

    1. delete the file located at

    /Users//Library/Application Support/Firefox/pluginreg.dat

    2. Restart Firefox.

    …as I said, it worked for me 🙂

  7. I suspect this may be an extension-related issue? Wondering how many of you have an extension such as Flashgot installed.

  8. I’ve had this problem, too, and in my case it was the Adblock extension. This is a known issue as of 0.7.5.1 when you have “Show tabs on Flash and Java” enabled. Go to about:config, and change extensions.adblockplus.frameobjects to false.

  9. had same problem, flash 9 plugin is installed, but i could not see any video in firefox. Removed Adblock (0.5.3.043) and everything worked fine again.
    thanks Rick

  10. It took me several hours – but here’s what finally worked (I’m not using AdBlock, but had the same problem) – MANUALLY find these plugins > Macintosh HD > Library > Internet Plug-Ins > Throw away your FLASH Plug-ins, I also threw out my Flip For Mac.

    Flip4Mac WMV Plugin.webplugin
    Flip4Mac WMV Plugin.plugin
    flashplayer.xpt
    Flash Player.plugin
    Flash Player Enabler.plugin

    you will now reinstall with the Flash Universal Binary Installer from

    “http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash”

    The reinstall places the plugins SOMEPLACE ELSE as they are no longer in my plug-ins folder but YouTube and Myspace are working perfectly now in Safari and Firefox. Simply using the installer without first removing the plug-ins did not work (as you have already discovered!)

    “Get Info” Safari and Firefox applications , be sure “Run Under Rosetta” is UNChecked.

    Hope this helps someone.

  11. I was running adblock, but when I looked at about:config there was no extensions.adblockplus.frameobjects listed. So I just disabled adblock altogether and it worked. Thank you, Rick! Before I found your posting, I spent many hours trying to figure it out without success.

  12. Rick: thanks a lot, flash videos work now!

    Laura: for me it ws adblock.frameobjects (so basically filtering for frameobjects should find the right one)

  13. Thanks guys. I suffered with this problem for months now. Finally I can see flash in firefox. I was going insane with how flash only showed up at the top/bottom of the screen.

  14. I recently upgraded to flash player 9 (for os x 10.4, PPC mac)

    Now no flash websites (youtube, etc) would work on my browser (firefox) or any others. With the help of this thread I found the files to delete and have done so. Now at least I’m able to see the websites backup image, but obviously no flash still.

    When I tried to re-install flash 9, now I am getting an error message “Creating file: 1008:5, -5000 Access Denied Error”, and that is followed by a message that says I do not have the privileges to install the player.

    I went to adobe’s website and found instructions on how to fix/bypass this with the Terminal program. Unfortunately, nothing seems to change when I follow the steps. And I still can’t install flash 9 onto my computer.

    Help! Please!!

  15. As soon as I updated my PPC to 10.4.11 all Flash content stopped working. All I see on in video frames is the quicktime “Q” with a question mark over it.

    None of the fixes in this thread have solved the problem. The only work around I’ve found is to re-install Flash each and every time I want to use Firefox. That gets me one surfing session. If I quit Firefox, Flash dies.

    Anyone care to guess WTF is up here?

    -d

  16. Hey Adam,
    Use the disk utility in the applications/utilities folder.
    Select the system disk and repair permissions!
    Then re-install that son of a ***** flash installer

    Good luck!

  17. I did a search for extensions.adblockplus.frameobjects, found adblockplus.js and opened it in Dreamweaver, edited to false, and replaced the original. worked. thanks!

  18. I run Internet Explorer 7.0 on Windows XP and whenever I try to get a Shock Wave video, a QuickTime Q appears with a ? inside it, and nothing plays. What can I do?

  19. I was trying to overlay an absolute positioned, z-Indexed div over a flash file. It worked in all browsers on PC and ins Opera and Safari on my Mac running OS X. In Firefox on the Mac, it would only render about the first 10px of the 250px high div. After many hours of frustration I tried setting display:block on the div via javascript (object).style.display = “block”; — and id WORKS!!
    Hope this helps someone.

  20. Adblock was the cause for me, Rick’s comment was the cure: Go to about:config, and change extensions.adblockplus.frameobjects to false.

    Thanks Rick!

  21. Rick Fletcher… you the man!
    removing the tabs from ADBLOCK extension worked. Firefox with the adblock tabs enabled on my PC works fine, but not on my MBP.

    about:config
    adblock.frameobjects (to false)

    or…
    you can do it from the options in tools<addons<adblock but about: config is easier.

Comments are closed.